THE LARGEST BMW 2-SERIES FORUM ON THE PLANET
2Addicts
2Addicts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2Addicts | BMW 2-Series forum Technical Topics B58 (M240i) Engine, Transmission, Exhaust, Tuning Throttle lag after shift 6MT

Post Reply
 
Thread Tools Search this Thread
      06-24-2022, 01:42 AM   #1
vincetamb7
New Member
1
Rep
8
Posts

Drives: BMW m240i 6MT
Join Date: Jul 2020
Location: Miami

iTrader: (0)

Throttle lag after shift 6MT

Whatís up yíall. Iíve had my 2020 m240i 6MT for a little over two years now. It has a BMS intake, VRSF catless dp, resonator delete, LUK 550i clutch, stage 2 BM3 OTS tune and spark plugs were changed at 26k (36k now)

Iím having an issue, not sure if everyone experiences this, and itís more noticeable with the tune running, but I cannot figure out why this happens for the life of me. So essentially, If Iím doing a meaty pull, after I shift gears 2-3 and up, not really 1-2, the revs fall relatively quick considering the new clutch and engagement isnít too rough. But when the revs fall and settle into the next gear, itís almost like power is cut for an entire second. So even if I bang the next gear and everything goes smoothly, thereís still a whole second I have to wait before power comes back on despite my right foot going through the floorboards.

If anyone has insight on this, if itís normal, if itís related to the tune, or anything else yíall can share ID appreciate it. This has been annoying me forever but I never really did too much research into it.
Appreciate 0
      06-24-2022, 11:24 AM   #2
delvec03
First Lieutenant
90
Rep
351
Posts

Drives: 228i Sport/ DSB
Join Date: Feb 2015
Location: United States, DC

iTrader: (0)

Could be a bit of turbo lag. If you haven't done the CDV delete, the slow clutch engagement couldn be contributing to slippage. I get a little slip on 2-3 if I'm not aggressive enough.

Another thing to consider is upgrading the diverter valve to GFB DV+. This is supposed to help hold boost between shifts and has had a noticble effect on my shifts, especially 1-2.
Appreciate 1
MLJR235116.50
      06-24-2022, 12:49 PM   #3
Toddbmw
Enlisted Member
95
Rep
38
Posts

Drives: F22
Join Date: Nov 2009
Location: North Carolina

iTrader: (0)

Experience the same on my 2017 M240i, full throttle to redline, then upshift (2-3), get a long second delay before the power returns.
Did remove the CDV, and have a Dinan Air Filter. Purchased the car used from a dealer, with the Dinan Air Filter, so don't know if it has a tune (doubt it).
Interesting on the diverter valve upgrade.
Appreciate 0
      06-24-2022, 02:11 PM   #4
vincetamb7
New Member
1
Rep
8
Posts

Drives: BMW m240i 6MT
Join Date: Jul 2020
Location: Miami

iTrader: (0)

Quote:
Originally Posted by delvec03 View Post
Could be a bit of turbo lag. If you haven't done the CDV delete, the slow clutch engagement couldn be contributing to slippage. I get a little slip on 2-3 if I'm not aggressive enough.

Another thing to consider is upgrading the diverter valve to GFB DV+. This is supposed to help hold boost between shifts and has had a noticble effect on my shifts, especially 1-2.
So yea the CDV was removed when the new clutch was installed. Iíll definitely look into the DV upgrade. Itís weird though because it doesnít feel like turbo lag, because I donít hear or feel boost being built again. It literally feels like the throttle simply closes for half a second. Entire power cut.
Appreciate 0
      06-24-2022, 02:25 PM   #5
Toddbmw
Enlisted Member
95
Rep
38
Posts

Drives: F22
Join Date: Nov 2009
Location: North Carolina

iTrader: (0)

Not finding a GFB DV+ diverter valve for the B58 engines.
Appreciate 0
      06-24-2022, 04:28 PM   #6
vincetamb7
New Member
1
Rep
8
Posts

Drives: BMW m240i 6MT
Join Date: Jul 2020
Location: Miami

iTrader: (0)

Quote:
Originally Posted by Toddbmw View Post
Not finding a GFB DV+ diverter valve for the B58 engines.
B58’s have a chargecooler not an intercooler. So they’re obsolete for these cars.
Appreciate 0
      06-25-2022, 04:20 PM   #7
JoanLluch
Enlisted Member
Andorra
31
Rep
42
Posts

Drives: F87 BMW M2 Comp M6T (2020)
Join Date: Mar 2017
Location: Encamp

iTrader: (0)

This was extensively discussed here, I think it may be the same issue https://f87.bimmerpost.com/forums/sh....php?t=1699999
Appreciate 0
      06-25-2022, 08:01 PM   #8
SpencerC_6MT
Second Lieutenant
SpencerC_6MT's Avatar
United_States
197
Rep
238
Posts

Drives: '17 M240i 6MT
Join Date: May 2017
Location: San Diego, CA /// Tuscaloosa, AL

iTrader: (0)

Garage List
2017 BMW M240I  [0.00]
I get the same issue occasionally, but it can happen under partial load or full throttle. Probably 2% of 2-3 shifts, I just lose power for a second with no explanation as to why.
Appreciate 0
      06-26-2022, 01:45 AM   #9
JoanLluch
Enlisted Member
Andorra
31
Rep
42
Posts

Drives: F87 BMW M2 Comp M6T (2020)
Join Date: Mar 2017
Location: Encamp

iTrader: (0)

Quote:
Originally Posted by watermelon3878 View Post
I get the same issue occasionally, but it can happen under partial load or full throttle. Probably 2% of 2-3 shifts, I just lose power for a second with no explanation as to why.
I'm intrigued as why for some people this does not happen, or only happens "occasionally". In my case, this happens every single time I perform a full throttle upshift on my M2 Comp, regardless of how fast I am. Wonder if different engines/cars behave differenty
Appreciate 0
      06-26-2022, 02:27 PM   #10
BillG2A
Private
BillG2A's Avatar
United_States
70
Rep
80
Posts

Drives: 2017 M240 6spd.
Join Date: Dec 2020
Location: Atlanta, GA

iTrader: (0)

Vincetamb7:

Recommend this YouTube video on data logging the B58. Highly recommended



It covers logging using BM3 and MHD JB4- Wastegate cycle, ignition Timing , fuel and other parameters

You can log on your phone. You can also submit logs to Kern by email , the author of the YouTube video

Bill
Appreciate 0
      06-27-2022, 12:52 PM   #11
XutvJet
Major General
5538
Rep
5,364
Posts

Drives: 2011 Cayman Base, 2016 M235
Join Date: Mar 2016
Location: Kansas City

iTrader: (-1)

I know this sensation and power delay on the 2-3 shift. My M235 used to do this all the time when I was running the Dinan Sport cheap piggyback. I took it off and it went away. I then added the Dinantronics Stage 2 piggyback and never had the issue and I've been running this setup for 3 years now.

As JoanLluch provided a link to, the M2 group has been dealing with this issue in stock and modded N55 and S55 6MTs for years. Everything I'm reading and what I've personally experienced points to a stock tuning issue. From the datalogs I've seen, it looks like the DME sees excessive commanded torque immediately after a shift and it kills power with the intent being transmission preservation.

I think the only reason I don't see it with my Dinantronics Stage 2 piggyback is because Dinan went to great lengths to keep their piggyback tune quite linear rather than the hard hitting torque you see with many flash tunes and less than ideal piggyback tunes.

OP - Consider putting the stock intake back on and see if that fixes the issue. Also, does the issue happen in Sport+, Traction, or DSC modes? The thought being that maybe fun killing nannies in the Comfort and Sport modes are sensing or expecting some wheel spin on the shift, thus killing power. I know that the nannies can be very aggressive, especially if you don't have an LSD. I ran without an LSD to 2 years and the nannies were constantly intervening and killing power in Sport mode.
__________________
The forest was shrinking, but the Trees kept voting for the Axe, for the Axe was clever and convinced the Trees that because his handle was made of wood, he was one of them.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:37 AM.




2addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST