THE LARGEST BMW 2-SERIES FORUM ON THE PLANET
2Addicts
2Addicts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2Addicts | BMW 2-Series forum Technical Topics Mechanical Maintenance and TSBs: Break-in | Oil & Fluids | Servicing | TSB Passenger side tail light malfunction

Post Reply
 
Thread Tools Search this Thread
      10-31-2015, 07:19 AM   #1
M235iMMD
Registered
3
Rep
2
Posts

Drives: 2014 M235I
Join Date: Jun 2015
Location: Rutland MA

iTrader: (0)

Passenger side tail light malfunction

Hey guys,
So last night I got in my car and got all sorts of codes for the rear tail light. The turn signal, reverse light, brake light, and two stage light all have malfunction codes. The only light that does work is the running light on that side. I plan to go to the dealership next week but I'm curious if anyone else has ran into this issue or has any ideas on what it might be.
I was hoping it was just a one time fluke thing but after multiple shut downs and restarts it's still the same issue. I even tried it the next day and same problem.
It's a 2014 m235 with 18k on it. Car is stock.
Thanks everyone
Attached Images
 
Appreciate 0
      10-31-2015, 09:40 PM   #2
zipphreak
Captain
No_Country
396
Rep
996
Posts

Drives: m235xi
Join Date: Sep 2014
Location: b00ty

iTrader: (2)

I had the bottom error and it was a faulty circuit board on the tail light. they ended up replacing the right rear tail light assembly.
Appreciate 0
      08-26-2016, 11:59 AM   #3
abdiel
Private
17
Rep
59
Posts

Drives: 2016 M235i xDrive
Join Date: Aug 2015
Location: MI

iTrader: (0)

Just had the same errors but for the left rear lights a few times these past two weeks. The errors cleared after a day the first time it happened but now is pretty much constant.
Appreciate 0
      08-27-2016, 06:47 AM   #4
zipphreak
Captain
No_Country
396
Rep
996
Posts

Drives: m235xi
Join Date: Sep 2014
Location: b00ty

iTrader: (2)

take it to the dealer.. its a known issue with lens cracking and water leaking into the assembly causing it to malfunction randomly.. they replaced the entire right rear assembly for free.
Appreciate 0
      09-08-2016, 03:18 PM   #5
abdiel
Private
17
Rep
59
Posts

Drives: 2016 M235i xDrive
Join Date: Aug 2015
Location: MI

iTrader: (0)

Turned out to be ground wire short.
Appreciate 0
      11-17-2016, 09:23 AM   #6
P2
First Lieutenant
P2's Avatar
33
Rep
330
Posts

Drives: 2016 M235i xDrive
Join Date: Mar 2006
Location: NW Chicago Land

iTrader: (0)

I have no warning and the right rear blinker is not functioning. The dealer is replacing the the whole assembly. Part on order. Odd there's no warning.
Appreciate 0
      01-25-2017, 10:36 AM   #7
P2
First Lieutenant
P2's Avatar
33
Rep
330
Posts

Drives: 2016 M235i xDrive
Join Date: Mar 2006
Location: NW Chicago Land

iTrader: (0)

The new part did not work. I left the dealer with no resolution. I reseated all associated fuses and it's been working for 2 months.
Appreciate 0
      12-03-2017, 12:42 PM   #8
gtmax500
Private First Class
United_States
62
Rep
129
Posts

Drives: 2016 MW M235xi
Join Date: Sep 2015
Location: Annapolis, MD

iTrader: (0)

Garage List
2016 BMW M235xi  [0.00]
Got these same codes intermittently last week then consistently this week. Took it into the dealer and turned out to be ground wire short as well (no lense cracking).

They overnighted a retro fit kit to replace both sides wiring harness since they said the driver side would be going soon as well. All is working now.
Appreciate 0
      12-06-2017, 10:14 PM   #9
Supernaut
Little Deuce Coupe
Supernaut's Avatar
United_States
341
Rep
610
Posts

Drives: SO M2C, EBII M235i
Join Date: Sep 2014
Location: Virginia Beach

iTrader: (0)

Garage List
2015 BMW M235i  [0.00]
2004 Mazda RX-8  [0.00]
Quote:
Originally Posted by gtmax500 View Post
Got these same codes intermittently last week then consistently this week. Took it into the dealer and turned out to be ground wire short as well (no lense cracking).

They overnighted a retro fit kit to replace both sides wiring harness since they said the driver side would be going soon as well. All is working now.
I had the same issue last month on the driver's side - an intermittent warning for a day, then constant. It was the ground wire short as well, but my dealer only replaced the bad side. I guess I wait for the other shoe to drop.
__________________
ex: 2004 Thermonuclear Yellow RX-8|6MT
2015 Estoril Blue M235i |6MT|slicktop|MP exhaust
2020 Sunset Orange M2C|6MT|Black 788s
Appreciate 0
      05-14-2018, 07:20 AM   #10
omega145
Second Lieutenant
omega145's Avatar
81
Rep
235
Posts

Drives: 2016 M235 Xdrive
Join Date: Nov 2012
Location: Long Island, NY

iTrader: (1)

Had the same thing happen to my drivers side lights on my 16' M235 xDrive. Dealer took the following action under warranty:
Replace left bulb socket - 63-21-7-370-291
Repair left tail cable - 61-12-2-448-168
Replaced bulb housing and installed updated ground cable repair kit.
So far, so good.
Appreciate 0
      05-16-2018, 07:38 AM   #11
IndyRed128i
Private
IndyRed128i's Avatar
54
Rep
79
Posts

Drives: 2016 228XI M Sport
Join Date: Jan 2016
Location: Dallas, TX

iTrader: (0)

http://www.2addicts.com/forums/showt...light+warranty

Had those exact same codes on mine, only the drivers side instead. Ended up being the ground wire.
Appreciate 0
      05-21-2018, 12:19 PM   #12
gtmax500
Private First Class
United_States
62
Rep
129
Posts

Drives: 2016 MW M235xi
Join Date: Sep 2015
Location: Annapolis, MD

iTrader: (0)

Garage List
2016 BMW M235xi  [0.00]
Got a consistent new code the past few days except this time it's "right turn signal malfunction" which I assume is the front turn signal. Anyone have problems with the front yet? I'm trying to avoid going to the dealer just yet since I still have all my mods installed.
Appreciate 0
      06-04-2018, 11:46 AM   #13
SmellyGreek
Private First Class
SmellyGreek's Avatar
United_States
14
Rep
170
Posts

Drives: Estoril Blue F22 M235i
Join Date: Apr 2011
Location: Cambridge, MA

iTrader: (1)

Garage List
Same issue, the SIB # is 63-05-17 (also listed in the thread linked above). Only word of caution is that the SIB says to retrofit both sides even if only one side is out -- my dealer didn't know this until they applied to BMWNA for reimbursement. It cost me an extra 2 days without my car (had to order parts for driver side, wait a day for them to arrive and complete installation), but it was all covered under warranty.
Appreciate 0
      12-12-2018, 03:15 PM   #14
P2
First Lieutenant
P2's Avatar
33
Rep
330
Posts

Drives: 2016 M235i xDrive
Join Date: Mar 2006
Location: NW Chicago Land

iTrader: (0)

I just had the same thing on the passenger side. All lights malfunctioned. The ground pin was burnt and the ground plug on the harness melted. They did a repair with a taillight ground cable retrofit. They charged BMW 180USD. I asked what causes this. No answer. I asked if the problem is widespread. No answer.
Appreciate 0
      02-11-2019, 03:18 PM   #15
Kieu-Anh
Registered
0
Rep
1
Posts

Drives: 2015 F22 228i
Join Date: Feb 2019
Location: West Hollywood, CA

iTrader: (0)

Same issue here, even after replacing tail light assemblies.

Thanks for the perspective.

Had major water intrusion in right side tail light assembly on my 2015 228i and minor condensation on the left, plus the "right two-stage tail lamp malfunction" warning.

BMW tried to charge me $1,000 to have both light assemblies replaced, despite my BMW CPO warranty (driven less than 5k miles since purchase nine months ago). I asked for Warranty Goodwill service and they covered 85%, and retrofitted additional ground cables to both lights and an add'l grounding strap.

A week later, even more warning lights: right two-stage brake lamp malfunction, right rear turn signal malfunction, reverse lamp malfunction, right brake lamp malfunction.

Taking it back in next week.
Appreciate 0
      02-21-2019, 03:07 AM   #16
Clear_Blue22
Second Lieutenant
Clear_Blue22's Avatar
78
Rep
249
Posts

Drives: 2018 230i MSport
Join Date: Jul 2017
Location: Alabama

iTrader: (0)

Garage List
2018 BMW 230i  [0.00]
Searched for this issue as I am also experiencing an intermittent fault of the right rear turn signal. It first happened after disconnecting the battery months ago for a Dinan elite tune install. It happened until I turned the car off and back on and went away for weeks. Over the months its becoming more and more frequent, but it would always sort itself out and work again. The really odd thing was if I turned on the hazards the light would work just fine.

It was good for about a month or so and a few days ago it acted up again. Its been days now and it's still faulted and the light doesn't work with the hazards on anymore either. It's on but extremely dim. BMW told me to just replace the bulb, since my nearest dealer is 2 hours away.... What grounding cable is faulty? Is it something that I can just tighten?
Appreciate 0
      02-21-2019, 11:23 AM   #17
714_2er
Lieutenant
714_2er's Avatar
79
Rep
454
Posts

Drives: 2015 AW M235i
Join Date: Jun 2013
Location: SoulCal, 714

iTrader: (0)

My 2015 is currently at dealership with moisture build up in both tail lights and left everything malfunction lol, willing to bet cracked lens and full replacement on both.
Appreciate 0
      03-02-2019, 05:35 PM   #18
Climate Changer
Private First Class
United_States
42
Rep
126
Posts

Drives: 2018 230i xdrive convertible
Join Date: Oct 2018
Location: New York

iTrader: (0)

Garage List
2018 230i xdrive co ...  [0.00]
2019 x3  [0.00]
My previous 2015 228 had all those multiple codes come on random a few times. They replaced the whole taillight. That happened about a year into the lease. Never had any other problems with the car.
Letís hope there will be a 2021 2 series convertible
Appreciate 0
      04-03-2019, 01:00 PM   #19
msiladin
Registered
United_States
0
Rep
1
Posts

Drives: BMW m235i
Join Date: Apr 2019
Location: Virginia

iTrader: (0)

Insufficient ground wiring

I just suffered the same tail light error issue on my 2016 m235i. Similarly to others I first saw intermediate and then pretty much consistent errors related to the passenger side tail light. At first the dealer thought the there was an issue with the battery - because they saw voltage related battery errors. So they replaced the battery and pronounced it fixed. However, the tail light errors appeared again. The dealer gave me a loaner and looked at it again. They called me and explained that the ground cable had oxidized (burned, not related to moisture). They indicated that the new housing now had 2 instead of only 1 ground wire.

They did not replace the driver side tail light. They said they would do so if it failed. The repair was covered under warranty (I only have 26k on it)
Appreciate 0
      04-05-2019, 01:22 PM   #20
MarcoZandrini
First Lieutenant
United_States
107
Rep
371
Posts

Drives: 2018 M240i
Join Date: Jun 2017
Location: Virginia

iTrader: (0)

The typical cause of a burned ground wire is excessive current has run through the wire at many times.
Appreciate 0
      06-11-2019, 03:24 PM   #21
Jacob657
New Member
0
Rep
10
Posts

Drives: 2018 BMW 230i Sport Line
Join Date: Sep 2017
Location: Mississippi

iTrader: (0)

2018 230i Rear Turn Signal Malfunction

I had the rear turn signal malfunction happen multiple times, randomly. Ended up bringing it to the dealer and they replaced it under warranty for free. Blamed it on moisture getting in the tail lamp and shorting a wire.
Appreciate 0
      06-11-2019, 09:17 PM   #22
Clear_Blue22
Second Lieutenant
Clear_Blue22's Avatar
78
Rep
249
Posts

Drives: 2018 230i MSport
Join Date: Jul 2017
Location: Alabama

iTrader: (0)

Garage List
2018 BMW 230i  [0.00]
Mines in right now for the same thing. I let it go for several months until it was due for service. Hope it finally gets resolved. It's really annoying to hear the gong go off every time it fails randomly when I go to use it exiting the neighborhood. Some times it will fail every drive. Then it would go for weeks working perfectly fine...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:37 PM.




2addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST