THE LARGEST BMW 2-SERIES FORUM ON THE PLANET
2Addicts
2Addicts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2Addicts | BMW 2-Series forum Technical Topics Mechanical Maintenance and TSBs: Break-in | Oil & Fluids | Servicing | TSB Clicking sound from front left wheel

Post Reply
 
Thread Tools Search this Thread
      01-20-2018, 07:53 AM   #45
orangeglim
Lieutenant
United_States
288
Rep
425
Posts

Drives: 2019 M2C
Join Date: May 2016
Location: NC

iTrader: (0)

Garage List
2019 M2C  [0.00]
Quote:
Originally Posted by Wagerd View Post
Waking this thread up again -- had the same procedure of "friction rings." Haven't had ticking return, but seems that there's more scrub. I'm actually growing concerned there is something just wonky about the front suspension geometry on this car. Have had it out in cold weather, and get tire scrub when turning at low speeds -- don't notice it in warm weather, I assume because the tire is more pliable when warm & just wears out the outer edge (which is further evidence about something wonky about geometry). I've had an e30M3, e46 330i ZHP, e40 M3, and NONE of them ever wore out the outside of a tire like this car. Also, none of them had freaky tire clunking when reversing in a tight turn. Something just isn't right. Has anyone found a better suspension setup that perhaps puts less stress on the front components and perhaps reduces this clicking?
Both my front tires were quite worn on the outer shoulder. I attributed it to the alignment being off, but when I had it checked, only the right side was off, the left was near perfect. I've read about the clunking when reversing, but either mine doesn't do it, or, I don't know what to listen for. Still good here on the clicking though, haven't heard it since.
Appreciate 0
      02-19-2018, 10:04 AM   #46
simoneves
Second Lieutenant
United_States
61
Rep
293
Posts

Drives: '16 228i DSB/THP/6MT
Join Date: Jan 2010
Location: San Rafael, CA, USA

iTrader: (1)

Mine still free of clicking since left wheel bearing in August. I thought it came back on the right for a bit but it went away again.

I also get scrub and clunks when backing off my driveway on a cold morning. I put it down to cold PSS tires jumping on the concrete.

Both front tires now completely smooth on the outer 2". Still plenty of groove in the middle, though.

Dinan springs and A/S3's in the spring.
Appreciate 0
      06-27-2019, 02:01 AM   #47
Burgwood
Enlisted Member
Burgwood's Avatar
Netherlands
1
Rep
41
Posts

Drives: M235i
Join Date: Aug 2014
Location: Netherlands

iTrader: (0)

Does this clicking also effects any parts?
Or is it just an annoying noise?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:54 PM.




2addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST