THE LARGEST BMW 2-SERIES FORUM ON THE PLANET
2Addicts
2Addicts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2Addicts | BMW 2-Series forum Technical Topics Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics Apple CarPlay issues

Post Reply
 
Thread Tools Search this Thread
      07-17-2019, 03:59 PM   #1
cyclingismylife
New Member
cyclingismylife's Avatar
United_States
9
Rep
24
Posts

Drives: BMW M240i
Join Date: Jun 2019
Location: Georgia

iTrader: (0)

Apple CarPlay issues

I searched and could not find anything about this other than past mentions that updates seem to have resolved. So I have a 2017 M240i that I recently purchased that has the Wi-Fi option on it. when looking through the Connected Drive menu I saw it listed CarPlay as an option to purchase for $80/yr so I purchased the subscription. I have a 7 that is on the latest iOS firmware 12.3.1.

So I can connect my phone and most of the time it will pull up CarPlay when I start the car (sometimes it will never connect). After a few minutes it will start to drop out the audio signal, whether streaming music or talking on the phone. Sometimes it will completely disconnect and then reconnect. It's basically useless so I have stopped using it. I mentioned this to the BMW tech expert and they told me it was a know issue and BMW hoped to have it resolved by the end of the year via an over the air update. So is everyone else having this problem too or it just me?
Appreciate 0
      07-21-2019, 04:21 PM   #2
cyclingismylife
New Member
cyclingismylife's Avatar
United_States
9
Rep
24
Posts

Drives: BMW M240i
Join Date: Jun 2019
Location: Georgia

iTrader: (0)

This seems to have been addressed with my iOS 13 update on my phone. In case you were wondering what this looks like go to thread https://www.2addicts.com/forums/show....php?t=1632180 .
Appreciate 0
      07-24-2019, 12:28 AM   #3
EstorilM240
Private
60
Rep
64
Posts

Drives: 2017 M240i 6MT
Join Date: Jan 2019
Location: California

iTrader: (0)

1 - BMW Software update web page. I've also had a lot of CarPlay connectivity issues on start up. I have an early production MY 2017 car and wonder if it's due to software. You could consider updating your software here, it may help with connectivity. Are these already updated with Over the Air updates?

2. Cost - was CarPlay not originally installed on your car? I thought BMW did not charge their $80/year subscription until MY 2019 - I don't have a subscription for my MY 2017.

3. For initial connectivity issues, turning off and on Wifi often helps (80%+), if it never connects, restarting the iPhone always works for me.
Appreciate 0
      07-25-2019, 12:01 PM   #4
cyclingismylife
New Member
cyclingismylife's Avatar
United_States
9
Rep
24
Posts

Drives: BMW M240i
Join Date: Jun 2019
Location: Georgia

iTrader: (0)

When I bought my car a month ago I didn't even realize CarPlay was an option until I was scrolling through the Connected Drive menus in the iDrive system and saw it as an option to purchase, it gave me a 1 year for $80 and I believe a 5 year for $300?? I just did the 1 year to try it out. Things still seem to be consistently working since I did the iOS 13 update on my phone so hopefully this trend will continue. I'll have my car in service Monday so I'll have the make sure everything is up to date on the iDrive system as well.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:40 AM.




2addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST