THE LARGEST BMW 2-SERIES FORUM ON THE PLANET
2Addicts
2Addicts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2Addicts | BMW 2-Series forum Technical Topics Navigation, iDrive, Audio, Video, Bluetooth, Phone, Cameras, Electronics CarPlay unreliability - BMW Software Update via USB stick?

Post Reply
 
Thread Tools Search this Thread
      07-24-2019, 12:41 AM   #1
EstorilM240
Private
60
Rep
62
Posts

Drives: 2017 M240i 6MT
Join Date: Jan 2019
Location: California

iTrader: (0)

CarPlay unreliability - BMW Software Update via USB stick?

I'm considering installing a media software update/partial software update to get newer iDrive software and hopefully make my CarPlay reliable.

1. My CarPlay connection with my 2017 M240i has been very unreliable throughout many different iOS updates 11 and 12 (currently 12.3.1, iPhone 8) and minor ones. CarPlay has worked very well and reliably with at least 7 other vehicles I've tried it on, though all were wired CarPlay and rentals.

40% of the time, the iPhone connects within 15 seconds of startup automatically

20% of the time, I need to go to the devices page and select Apple CarPlay, and it connects

30% of the time, I have to manually connect as above, but it gets stuck on "Connecting to Apple Carplay... This may take some time" for 30+ seconds, then fails with "Connection failed. Retry/OK". It works when I turn off and on wifi on my iPhone. I tried searching, and surprisingly no results on these forums with that exact quoted message, but plenty of people on Apple forums suggesting re-connecting Wifi.

In 9.7% of cases, I have to restart my iPhone.

In the last 0.3% of cases, I have to completely re-pair my phone with the car

This has proven aggravating, especially since these cars don't have wired CarPlay (right?) in which I could connect in 5 seconds by plugging in

I suspect this is actually a software issue on the car side and not an iOS issue. Thus, I'm thinking of installing the BMW software update through a USB stick

I enter my VIN, and get:

Quote:
Software Update found: UPD09032
The Software Update is valid for BMW M240I, 2016, __VIN__
For detailed information on the new and customized features, please refer to the PDF "Software Update Information".

If the download does not start or there isn’t any PDF content shown please right-click on the download button and save the file with "Save target as...".

Software Update Information (PDF, 1.53 MB)
Software Update User Agreement (PDF, 1.49 MB)
Download UPD09032.bin (120 MB)
What's amazing is that it says it is for BMW M240i, 2016. I know my car was produced in 2016, so maybe that is why.

Looking at this page: https://www.bimmer-tech.net/blog/ite...-do-it-and-how

Quote:
More common, though, is a partial software update, or media software update. This may cover things like multimedia, Bluetooth, Internet connectivity, or mobile compatibility with the latest version of Apple iOS or Samsung/Android system.. Any owner can install this kind of update themselves as long as their car features a Combox, which works with iDrive and enhances many technology features in your BMW.
Questions:
1. Should I already have this software update as part of "over the air" update? I thought that wasn't possible?

2. Will I have to start paying $80/year for CarPlay if I upgrade software? The car was bought with CarPlay as an option as part of Executive Package I think, so I hope not... I really don't want another bill and something that can disconnect me at random

3. Is it really true that there is no way to get wired CarPlay? No iDrive special editions anywhere?

4. Many people in other threads are warning against software updates https://f30.bimmerpost.com/forums/sh....php?t=1515996 and taking forever, but it looks like only the ECU/main software updates are bad, and not the infotainment/media one?

5. I'd much rather do this myself and really avoid the dealership - the chance of "bricking" the car completely should be nil, yes?

6. Anyone else had CarPlay connectivity issues that were solved by doing this?

Last edited by EstorilM240; 07-24-2019 at 12:47 AM..
Appreciate 0
      08-10-2019, 05:28 PM   #2
M3nt4l
Private
17
Rep
60
Posts

Drives: BMW F20, BMW E91
Join Date: Feb 2019
Location: England

iTrader: (0)

Did your vehicle come with CarPlay which was purchased via the ConnectedDrive or was it a 3rd Party solution?

If you can use a vin decoder to see what options were installed in your car from factory and post here that would be great. It seems as if you don't have the WiFi antenna installed and hence your getting these connectivity issues. I have seen this in many cars who have had a 3rd party CarPlay activation but then havent had the WiFi antenna installed.

Does your phone have to be quite close to the headunit in order for it to connect?
__________________
Vehicle Diagnostics and Coding
ISTA ESYS
CarPlay Activation
Sat Nav Map Updates
SLI FSC
Appreciate 0
      08-12-2019, 12:40 AM   #3
EstorilM240
Private
60
Rep
62
Posts

Drives: 2017 M240i 6MT
Join Date: Jan 2019
Location: California

iTrader: (0)

The vehicle came with CarPlay stock from the factory, so I believe I do have the Wifi antenna:
S609A Navigation System Professional
S6CPA Preparation Apple CarPlay

If I didn't have the wifi antenna installed, wouldn't CarPlay just refuse to work completely?

You bring up a very good point that it may be caused by head unit proximity. A lot of the time, I do bring the phone out into the cupholder, and retry, but that doesn't seem to help. Anyway, I'm spurred to go update the software and see how it works the next few weeks. The main reason I haven't is a small, latent fear that it will make me pay $80/year for the subscription, despite the MY2017 having the lifetime option.
Appreciate 0
      08-12-2019, 02:19 AM   #4
M3nt4l
Private
17
Rep
60
Posts

Drives: BMW F20, BMW E91
Join Date: Feb 2019
Location: England

iTrader: (0)

Quote:
Originally Posted by EstorilM240 View Post
The vehicle came with CarPlay stock from the factory, so I believe I do have the Wifi antenna:
S609A Navigation System Professional
S6CPA Preparation Apple CarPlay

If I didn't have the wifi antenna installed, wouldn't CarPlay just refuse to work completely?

You bring up a very good point that it may be caused by head unit proximity. A lot of the time, I do bring the phone out into the cupholder, and retry, but that doesn't seem to help. Anyway, I'm spurred to go update the software and see how it works the next few weeks. The main reason I haven't is a small, latent fear that it will make me pay $80/year for the subscription, despite the MY2017 having the lifetime option.
Ah I see.

No, I have done a CarPlay activations on vehicles which do not have the WiFi antenna and it will connect it's just the phone has to be right near the headunit (in the cup holder).

Might be worth just pulling the headunit out to check?

If not do all the relevant updates and go from there.
__________________
Vehicle Diagnostics and Coding
ISTA ESYS
CarPlay Activation
Sat Nav Map Updates
SLI FSC
Appreciate 0
      08-13-2019, 10:45 AM   #5
cyclingismylife
New Member
cyclingismylife's Avatar
United_States
9
Rep
24
Posts

Drives: BMW M240i
Join Date: Jun 2019
Location: Georgia

iTrader: (0)

I updated the BMW software using the link you provided and a USB stick and had no issues FWIW.
Appreciate 0
      08-18-2019, 06:23 PM   #6
Hekler
Private First Class
6
Rep
120
Posts

Drives: 2019 M240i Black on Black
Join Date: May 2019
Location: SoCal

iTrader: (0)

Quote:
Originally Posted by cyclingismylife View Post
I updated the BMW software using the link you provided and a USB stick and had no issues FWIW.
So you got car play to work? Android and Apple? What system do you have? Thank you!!
Appreciate 0
      08-19-2019, 01:29 PM   #7
cyclingismylife
New Member
cyclingismylife's Avatar
United_States
9
Rep
24
Posts

Drives: BMW M240i
Join Date: Jun 2019
Location: Georgia

iTrader: (0)

I did, but in the process i have also updated my iPhone 7's iOS to the Beta 13 and it has been working flawless ever since. I don't think the iDrive update I did to the car addressed my issue though because it was working before that (in my case I think the iPhone update fixed my problems), I just did the car update to make sure the iDrive system was at the latest version.
Appreciate 0
      08-19-2019, 11:43 PM   #8
EstorilM240
Private
60
Rep
62
Posts

Drives: 2017 M240i 6MT
Join Date: Jan 2019
Location: California

iTrader: (0)

I also updated my software yesterday and so far the results are positive. Nothing broke, and in the (single digit) number of times I've started the car with the phone inside, Apple CarPlay has connected well. I'll see how it does the rest of the week, hopefully it keeps up.

FWIW I'm still using iOS 12 and the CarPlay reliability issues seem to be gone - I had issues in the past with multiple versions of iOS 11 and 12.

Telephone software version went from TB-003.010.003 to TB-003.012.032, Media stayed at MB-003.010.003 to MB-003.010.003, and a new HMI appeared with HB-006.007.032

The phone continues to connect when it's far from the head unit too

Quote:
Originally Posted by Hekler
So you got car play to work? Android and Apple? What system do you have? Thank you!!
Note that there is no Android Auto available on BMW, but you can still use the ConnectedDrive apps like Spotify etc. with it.
Appreciate 0
      08-25-2019, 05:08 PM   #9
EstorilM240
Private
60
Rep
62
Posts

Drives: 2017 M240i 6MT
Join Date: Jan 2019
Location: California

iTrader: (0)

After a full week unfortunately many of the reliability issues returned - I would get the "Connection failed. Retry/OK" message, and the phone wouldn't connect until I turned off/on the wifi on the phone. I had one instance as well where I had to do a full restart of the phone. From the limited experience it may be marginally better than before but it's hard to tell for sure. Will update to iOS 13 once it's out of beta, crossing fingers that this solves it
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:43 AM.




2addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST