THE LARGEST BMW 2-SERIES FORUM ON THE PLANET
2Addicts
2Addicts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2Addicts | BMW 2-Series forum Technical Topics N55 (M235i) Engine, Transmission, Exhaust, Tuning OMG VRSF ChargePipe

Post Reply
 
Thread Tools Search this Thread
      03-07-2020, 10:14 AM   #1
123Britt
Captain
United_States
168
Rep
678
Posts

Drives: 15 M235i AT
Join Date: May 2008
Location: Madison, Alabama

iTrader: (0)

OMG VRSF ChargePipe

Installed
Attached Images
  

Last edited by 123Britt; 03-14-2020 at 10:48 AM..
Appreciate 0
      03-07-2020, 02:19 PM   #2
khj24
First Lieutenant
133
Rep
335
Posts

Drives: 2015 m235i
Join Date: Apr 2018
Location: 713

iTrader: (3)

It's fine, it'll just be that green o ring that compresses. If you put a bit of oil on there it'll side on nicely with some force. Definitely a reassuring seal, I wouldn't mess with it.
Appreciate 0
      03-07-2020, 04:22 PM   #3
123Britt
Captain
United_States
168
Rep
678
Posts

Drives: 15 M235i AT
Join Date: May 2008
Location: Madison, Alabama

iTrader: (0)

Actually Mine would NOT

Quote:
Originally Posted by khj24 View Post
It's fine, it'll just be that green o ring that compresses. If you put a bit of oil on there it'll side on nicely with some force. Definitely a reassuring seal, I wouldn't mess with it.

Yes the Green - O-Ring.
Attached Images
 

Last edited by 123Britt; 03-14-2020 at 10:51 AM..
Appreciate 0
      03-07-2020, 06:02 PM   #4
khj24
First Lieutenant
133
Rep
335
Posts

Drives: 2015 m235i
Join Date: Apr 2018
Location: 713

iTrader: (3)

Mine wasn't chamfered at all, I guess yours was tapped a little too small like you said then. Hope the tmap sits deep enough with your setup!
Appreciate 0
      03-08-2020, 10:11 PM   #5
drodrig2
New Member
11
Rep
18
Posts

Drives: m235i
Join Date: May 2012
Location: new mexico

iTrader: (0)

The VRSF charge pipe I just got yesterday has the same problem as yours. What Champherd / CounterSink bit size did you use?
Appreciate 0
      03-09-2020, 03:50 PM   #6
123Britt
Captain
United_States
168
Rep
678
Posts

Drives: 15 M235i AT
Join Date: May 2008
Location: Madison, Alabama

iTrader: (0)

3/4 Countersink

Nice

Last edited by 123Britt; 03-14-2020 at 10:50 AM..
Appreciate 0
      03-09-2020, 09:27 PM   #7
Dynamic_m235
Second Lieutenant
40
Rep
208
Posts

Drives: 2016 m235i xDrive
Join Date: Feb 2017
Location: North Jersey

iTrader: (0)

Quote:
Originally Posted by 123Britt View Post
Installed the VRSP 5 HD Intercooler and Charge Pipe less the TMAP Sensor on the charge pipe because I noticed a blemish on the seal -- so I ordered a new seal.

No problem right? All the work of installation was really done - just the simple TMAP sensor install.

Well - once I got the new seal , I attempted to install the Cleaned Sensor and with new seal. OMG -- it does not fit!!!

After reviewing the OEM Chargepipe I noticed a significant chamfer on the opening of the port. While the VRSF ChargePipe MAP Sensor opening is only deburred but NO CHAMPHER. (see photos)

I have now taken the entire IC and ChargePipe back off the car and I guess I will go to Home Depot to buy a champher bit .


So -- Lesson Learned: Check that your VRSF ChargePipe will accept the TMAP Sensor. The way that it is (without a champher) -- you will either break the TMAP or trash the seal on installation. I have pushed like hell to get mine installed. Once I champher the opening - I am sure it will compress the seal and be a tight fit.

How frustrating!!!!!!!
I had a vrsf chargepipe and it rubbed on my steering rack till it poked a hole through. Their chargepipe isn't made right to fit directly, most people have problems like me
Appreciate 0
      03-24-2020, 09:22 AM   #8
Tiago@VRSF
Tiago@VRSF's Avatar
United_States
1878
Rep
40,567
Posts

Drives: F82 M4, M6 GC, F85 X5M, F90 M5
Join Date: Dec 2007
Location: Miami, FL

iTrader: (99)

Garage List
Quote:
Originally Posted by Dynamic_m235 View Post
I had a vrsf chargepipe and it rubbed on my steering rack till it poked a hole through. Their chargepipe isn't made right to fit directly, most people have problems like me
This issue only affected a small portion of XI charge pipes and has been rectified via a redesign. Please contact support@vr-speed.com for a replacement
__________________
Appreciate 0
      03-24-2020, 10:58 AM   #9
Dylan86
Colonel
Dylan86's Avatar
Canada
1152
Rep
2,099
Posts

Drives: Hard
Join Date: Jan 2016
Location: GTA

iTrader: (0)

I had to give it a bit of oil and push/twist it in firmly, it almost seemed like it wanted to cut the o-ring without any "lube" but went in at the end, been on for 3 years no issues whatsoever...
__________________
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:58 PM.




2addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST