THE LARGEST BMW 2-SERIES FORUM ON THE PLANET
2Addicts
2Addicts
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
2Addicts | BMW 2-Series forum Technical Topics N20 (228i) / B46 (230i) Engine, Transmission, Exhaust, Tuning 2017 230i xDrive 8AT B46O SULEV Engine Strange Turbocharger Whine Noise

Post Reply
 
Thread Tools Search this Thread
      12-14-2023, 02:20 PM   #1
TheKrumpet
Registered
0
Rep
1
Posts

Drives: 2017 BMW 230i xdrive
Join Date: Dec 2023
Location: STL

iTrader: (0)

2017 230i xDrive 8AT B46O SULEV Engine Strange Turbocharger Whine Noise

Hey guys bought this 2017 230i xDrive 8AT B46O with 53k miles recently and I've noticed a high pitched whining noise that corresponds to being on the throttle or anytime the engine is between 1200-2200 rpm (sound exists higher but is so high pitched you can't really discern it with road and engine noise). I can hear it in the cabin or the engine bay during cold starts and whenever I'm lugging around town in stop and go or regular traffic where I'm not regularly going above 2500rpm.

A/C doesn't affect the noise, driving or in park doesn't affect the noise, and neither does SPORT+ or COMFORT (exhaust valve?). I found a VR tuned Chip tuner the first days I had it (in line with MAP and Turbo Inlet sensor which I removed). Worried maybe the turbocharger was abused? Is this noise normal? I examined the chargepipe and intake piping and did a quick inspection of the turbo impellers and it all seemed fine with no extra loose parts that could maybe cause a leak. Could this be a vacuum leak? Or would upping my oil weight to 5w-30 help?

I already took it to a BMW dealership and they tried to charge me $230 for not being able to replicate the noise... but it's present in any condition. Essentially a useless experiment. Never going back to a dealership for this kind of troubleshooting again lol.

Any suggestions appreciated...would rather not replace the turbo so soon. Anyway see attached videos:

https://www.youtube.com/shorts/duZxW5deH38

https://www.youtube.com/shorts/7siXKLjqOkE
Appreciate 0
      03-22-2024, 04:48 AM   #2
Chelbaradu
New Member
0
Rep
7
Posts

Drives: bmw F36 430i
Join Date: Jun 2022
Location: romania

iTrader: (0)

hey, I found your post and I have the same problem... exactly the same sound under the same conditions.. did you manage to solve it or find out the cause?
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:33 PM.




2addicts
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST